domingo, 23 de febrero de 2014

This version of the rendering library is more recent than your version of ADT plug-in. Please update ADT plug-in

Hoy me encontrado con este error :
This version of the rendering library is more recent than your version of ADT plug-in. Please update ADT plug-in

Justo hoy he arrancado un nuevo proyecto Android y la versión de destino es la 4.4.2 por lo que he actualizado el SDK, instalando dicha versión y descargando las actualizaciones de las anteriores que se me quedaron anticuadas, para mi sorpresa cuando abro el activity no tenia nada visible, y me aparecía dicho error después de ir a help -> check for Updates y que me dijera que no tenia ninguna actualización estaba desconcertado y googleando encontré lo siguiente:

http://stackoverflow.com/questions/18852983/eclipse-reports-rendering-library-more-recent-than-adt-plug-in

Allí dicen simplemente que le demos a help -> install New Software, en donde veremos una pantalla como la siguiente


Allí deberemos teclear la siguiente URL: https://dl-ssl.google.com/android/eclipse/

y seleccionar Developer Tool; darle a Next y esperar a que termine, cuando lo haga nos dirá que necesita reiniciar eclipse, le diremos que si y listo

Un saludo y espero que os sirva de utilidad.